[MEncoder-users] Skipping frames while copying video

Aaron Digulla digulla at hepe.com
Sun Aug 6 17:29:26 CEST 2006


I'm trying to concatenate several video streams which I created with my
digital camera into one AVI file.

The source is Quicktime (.mov)

VIDEO:  [jpeg]  640x480  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
AUDIO: 7875 Hz, 1 ch, u8, 63.0 kbit/100.00% (ratio: 7875->7875)
(Uncompressed PCM)

I tried this:

mencoder -ovc copy -oac pcm -idx -o test.avi dscn189[1-9].mov

Problem: Every 10th frame is skipped or duplicated and I end up with a
file with 232.5 seconds of video and 233.5s audio :-(

So I tried to force 30fps with "-ofps 30" and I added "-noskip" but to
no avail. Why is mencoder skipping frames while copying a video?

I'm using version 1.0pre8.


Aaron "Optimizer" Digulla a.k.a. Philmann Dark
"It's not the universe that's limited, it's our imagination.
Follow me and I'll show you something beyond the limits."

More information about the MEncoder-users mailing list