[MEncoder-users] a-v synchronization problems of some NTSC DVDs with -oac copy

David Soukal david.soukal at binghamton.edu
Tue Apr 26 03:06:36 CEST 2005


I have downloaded and compiled MPlayer from CVS sources yesterday and
tried to compress another movie. It seems that the problem is still
there. In my last attempt I tried sequence: no inverse telecine then
pullup,softskip and then softpulldown,ivtc=1 all of them with the same
result: there's slight delay in the sound stream playback.

I even tried to compress the DVD directly from the disc, instead of
first decrypting it to the harddrive.

I don't know what happened. I processed a lot of movies with MPlayer but
recently, almost none works..

MPlayer plays all the movies in question without slightest problem.
MEncoder, no matter what settings, is always off a little bit. I
reported that compressing the audio stream works, it seems that with the
last movie this theory is no longer true -- even Lame encoded audio
stream is slightly off.

The pullup filter complains about duplicate frames and so does
softpulldown. Softpulldown reporst another thing that I have not seen
before "softpulldown: Unexpected field flags", here's an example with a
small context:

Pos:5854.8s 140419f (82%)  22fps Trem:  21min 1641mb  A-V:0.035 [1495:448]
1 duplicate frame(s)!
Pos:5854.9s 140421f (82%)  22fps Trem:  21min 1641mb  A-V:0.041 [1495:448]
demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
Warning! FPS changed 23.976 -> 29.970  (-5.994000) [4]  V:0.044 [1495:448]
Pos:5855.3s 140431f (82%)  22fps Trem:  21min 1641mb  A-V:0.022 [1495:448]
demux_mpg: 24000/1001fps progressive NTSC content detected, switching
Pos:5857.3s 140479f (82%)  22fps Trem:  21min 1640mb  A-V:0.084 [1495:448]
Skipping frame!
softpulldown: Unexpected field flags: state=1 top_field_first=1
Pos:5862.0s 140594f (82%)  22fps Trem:  21min 1640mb  A-V:-0.008 [1494:448]
1 duplicate frame(s)!
Pos:5874.7s 140898f (83%)  22fps Trem:  21min 1637mb  A-V:-0.004 [1492:448]

This log was generated during the first pass invoked by the following code



mencoder dvd://1 -dvd-device "$src" -aid 128 -ofps 24000/1001 -vf ${vf}
-oac copy -ovc xvid -xvidencopts pass=1:${xvidencopts} -o movie.avi

Very odd thing is that I have processed many movies in the past and
everything was ok until very recently. I noticed that the maintainter of
the Gentoo "package" of MPlayer has made modification so that I had to
recompile MPlayer with the DTS USE flag that according to the
documentation compiles MPlayer with libdts. Without that, MPlayer
wouldn't decode AC3 5.1 and only try passthrough mode that does not work
with my card. However, after I recompiled MPlayer, playback worked. This
has probably nothing to do with the problem but it's the only thing I
can think of that has changed.

BUT, I have downloaded the latest (Monday) sources of MPlayer and FFMpeg
from CVS and recompiled MPlayer and libavcodec from scratch. The
problems are still there.

I update my Gentoo system quite often so perhaps something external to
MPlayer has changed. Is there any other library not packed with MPlayer
that might cause these problems?

Thank you all very much for your help,


Rich Felker wrote:
> On Sun, Apr 24, 2005 at 01:29:00PM -0400, David Soukal wrote:
>>I have recently ran into A-V synchronization problems while encoding
>>some NTSC DVDs. I looked at the mailing list archive and found very
>>similar symptoms in a thread by Corey Hickey on March 15th ("a-v sync
>>problems with pullup, softskip (only on some DVDs)"). I have studied the
>>answers but I was unable to fix the problem. It seems that the problem
>>was a bug in the code that has been fixed. But I didn't find a reference
>>to the version of MPlayer that has the bug fixed. I'm using version
>>1.0pre6 compiled from sources on a Gentoo system (For Gentoo users: I
>>had to recompile MPlayer recently with the dts flag to get FFMPEG
>>support again.)
> Do not report bugs in old versions. Upgrade to CVS or at least
> 1.0pre7. If you look at the release dates and that discussion on March
> 15, 1.0pre6 is MUCH MUCH older..
>>Some observations that I made:
>>1) the sync problem would be there even if I omitted pullup and softskip
>>filters. One DVD that I have has first telecined content in the middle
>>of the movie, however the sync problems would be there from the very
>>beginning (with or without pullup,softskip)
> This suggests it may be a different problem. But please always try
> upgrading first.
> Rich
> _______________________________________________
> MEncoder-users mailing list
> MEncoder-users at mplayerhq.hu
> http://mplayerhq.hu/mailman/listinfo/mencoder-users

More information about the MEncoder-users mailing list