[MEncoder-users] xvidencopts is not an MEncoder option

Alexey com at nforum.de
Sun Apr 10 05:34:01 CEST 2005

Hi all,

have there been some recent changes with mencoder? A script of mine that
encodes video with xvid-codec gives me an error that "xvidencopts is not
an MEncoder option". I checked the syntax and also tried out some older
version that worked 100% and they give the same error.

I updated mplayer to the newest version and than downgraded it to
1.0pre5-r5 again (gentoo portage). Maybe something got mixed up.

This is the COMMAND:

mencoder dvd://6 -dvd-device /home/user/tmp/image -nosound -ovc xvid
-xvidencopts :bitrate=-2000000:pass=1:vhq=4:me_quality=6:chroma_me:quant_type=mpeg:max_bframes=2:gmc -o /home/user

And this is the OUTPUT:

MEncoder 1.0pre5try2-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon Thunderbird 1184 MHz (Family: 6,
Stepping: 2)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
CPUflags: Type: 6 MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX 3DNow 3DNowEx

Reading /home/user/.mplayer/codecs.conf: Can't open
'/home/user/.mplayer/codecs.conf': No such file or directory
Reading /usr/share/mplayer/codecs.conf: 73 audio & 180 video codecs
File not found: 'frameno.avi'
Failed to open frameno.avi
Reading config file /home/user/.mplayer/mencoder: No such file or
xvidencopts is not an MEncoder option
Exiting... (error parsing cmdline)

Any ideas?



More information about the MEncoder-users mailing list