[FFmpeg-user] Repeatable resolution issue exporting mxfs, 1080p is coming out as 1088p

Michael Koch astroelectronic at t-online.de
Mon Feb 27 17:34:18 EET 2023

Am 27.02.2023 um 16:07 schrieb William Jones:
> Hi All,
> I'm having a big problem with ffmpeg at the moment and wanted to pry the
> minds of anyone who may know.
> Trying to export a image sequence as a .mxf file at 1920x1080, DnxHD 115.
> Unfortunately every time I try, the resulting file comes out as 1920x1088
> which breaks our pipeline. Ive tried using scale and have tried the source
> file being different formats (image sequences or .movs etc) and nothing has
> helped so far, which is why the below  code doesnt have any scale modifiers
> in it.
> the code i have been using is below:
> ffmpeg - start_number 1000 -i *-inputfile%4d.tiff* -c:v dnxhd -r 24
> -b:v115M -pix_fmt yuv422p *outputfile.mxf*
> Any help at all would be much appreciated!

Seems to be a bug. The issue is reproducible with these command lines 
(started from a Windows batch file):

ffmpeg -f lavfi -i testsrc2=s=1920x1080 -frames 10 -y image%%3d.tiff
ffmpeg -i image%%3d.tiff -c:v dnxhd -r 24 -b:v 115M -pix_fmt yuv422p -y 

FFprobe reports 1920x1080, but ExitTool reports 1920x1088.


More information about the ffmpeg-user mailing list