[FFmpeg-user] Problem while converting DNG sequnece to video file

Michael Koch astroelectronic at t-online.de
Fri Aug 21 22:34:05 EEST 2020

Am 20.08.2020 um 09:57 schrieb Masala Kentaro:
> hello!
> I have problems using FFmpeg, while trying to convert DNG-sequence
> into mp4/mov/avi video file.
> While converting, I also need to downgrade the resolution of the video
> from original 6016x3200 to 2030x1080.
> First problem: I got almost black screen in the resulting video. Had
> to play with gamma and brightness options, but there were still
> obvious problems with saturation and contrast after that.
> (I tried simple DNG to PNG conversion of a single file, and it also
> results in almost black screen, command:
> ffmpeg -v 9 -loglevel 99 -i e:\12345\sample_r00001.dng e:\output.tga)

Let's not forget that the original poster of this thread had a question. 
I can't answer it, but I did try to reproduce it.
I took a RAW CR2 image from my Canon 6D, converted it to DNG with Adobe 
DNG Converter 12.4, and then tried to convert it to JPG with FFmpeg:

ffmpeg -i IMG_3459.dng out_6D.jpg

This didn't work, see the console output below.
I also tested with a RAW image from a Canon 5D-MK4, with the same 
negative result.


C:\Users\astro\Desktop\dng>c:\ffmpeg\ffmpeg -i IMG_3459.dng out_6D.jpg
ffmpeg version git-2020-08-21-412d63f Copyright (c) 2000-2020 the FFmpeg 
   built with gcc 10.2.1 (GCC) 20200805
   configuration: --enable-gpl --enable-version3 --enable-sdl2 
--enable-fontconfig --enable-gnutls --enable-iconv --enable-libass 
--enable-libdav1d --enable-libbluray --enable-libfreetype 
--enable-libmp3lame --enable-libopencore-amrnb 
--enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus 
--enable-libshine --enable-libsnappy --enable-libsoxr --enable-libsrt 
--enable-libtheora --enable-libtwolame --enable-libvpx 
--enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 
--enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib 
--enable-gmp --enable-libvidstab --enable-libvmaf --enable-libvorbis 
--enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex 
--enable-libxvid --enable-libaom --enable-libgsm --enable-librav1e 
--enable-libsvtav1 --disable-w32threads --enable-libmfx 
--enable-ffnvcodec --enable-cuda-llvm --enable-cuvid --enable-d3d11va 
--enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth 
--enable-libopenmpt --enable-amf
   libavutil      56. 58.100 / 56. 58.100
   libavcodec     58.100.100 / 58.100.100
   libavformat    58. 51.100 / 58. 51.100
   libavdevice    58. 11.101 / 58. 11.101
   libavfilter     7. 87.100 /  7. 87.100
   libswscale      5.  8.100 /  5.  8.100
   libswresample   3.  8.100 /  3.  8.100
   libpostproc    55.  8.100 / 55.  8.100
[tiff @ 000001f73e39f440] Assuming black level pattern values are identical
[tiff @ 000001f73e39f440] Tiled TIFF is not allowed to strip
[tiff_pipe @ 000001f73e39d400] Stream #0: not enough frames to estimate 
rate; consider increasing probesize
[tiff_pipe @ 000001f73e39d400] decoding for stream 0 failed
[tiff_pipe @ 000001f73e39d400] Could not find codec parameters for 
stream 0 (Video: tiff, none): unspecified size
Consider increasing the value for the 'analyzeduration' (0) and 
'probesize' (5000000) options
Input #0, tiff_pipe, from 'IMG_3459.dng':
   Duration: N/A, bitrate: N/A
     Stream #0:0: Video: tiff, none, 25 tbr, 25 tbn, 25 tbc
Stream mapping:
   Stream #0:0 -> #0:0 (tiff (native) -> mjpeg (native))
Press [q] to stop, [?] for help
[tiff @ 000001f73e3a5f80] Assuming black level pattern values are identical
[tiff @ 000001f73e3a5f80] Tiled TIFF is not allowed to strip
Error while decoding stream #0:0: Invalid data found when processing input
Cannot determine format of input stream 0:0 after EOF
Error marking filters as finished
Conversion failed!

More information about the ffmpeg-user mailing list