[FFmpeg-user] Giving a title to an audio stream

PPRJ01 pprj01 at orange.fr
Sat Aug 8 18:35:29 EEST 2020

Thank you Peter, but (in my understanding) the following syntax is right (at least under Windows) :

ffmpeg -i INPUT.mp4 -c copy -metadata:s:a:0 "title=5.1" OUTPUT.mp4

For 3 reasons :
1- the ffmpeg stderr output displays "title : 5.1", with no warning, because it parsed it correctly and wrote it correctly "somewhere".
2- VLC software does retrieve the audio title correctly
3- exiftool software does retrieve the audio title correctly too

I have observed too that -metadata:s:a:0 "language=fre" is correctly written by ffmpeg and correctly retrieved by ffprobe in its TAG section.

Therefore I repeat my question to All : why ffprobe does not retrieve the audio and subtitle stream titles while VLC and exiftool do it properly?

Is this a designed behavior ?



On 08/08/2020 13:21, PPRJ01 wrote:
> Hello All,
> I don't understand how ffmpeg/ffprobe manage some metadata of audio streams.
> Let's take a simple example :
> ffmpeg -i INPUT.mp4 -c copy -metadata:s:a:0 "title=5.1" OUTPUT.mp4
> The result is :
> 1- ffprobe is not able to retrieve the audio title of the resulting file, whatever are the options used (I don't know if there are undocumented options)
> 2- VLC does retrieve the audio title correctly
> 3- exiftool does retrieve the audio title too
> I tried to do something similar with a subtitle stream and I had the same result.
> I am not a developper. Therefore I cannot read the source code. Maybe ffmpeg stores this metadata in a place where ffprobe is not able to retrieve it.
> Does somebody know if this is a normal behavior ?
> Rgds
> Pascal
I have found in recent versions that FFmpeg is ignoring certain flags in metadata commands (especially subtitles). In any event, your quotes are in the wrong place; try:

-metadata:s:a:0 title="5.1" -metadata:s:a:0 language=eng -disposition:a:0 default

("default" means display, "none" means suppress)


More information about the ffmpeg-user mailing list