[FFmpeg-user] hw_decode.c on osx?

Carl Eugen Hoyos ceffmpeg at gmail.com
Tue Apr 21 00:49:32 EEST 2020

Am Mo., 20. Apr. 2020 um 13:45 Uhr schrieb Edward Park <kumowoon1025 at gmail.com>:
> > you've probably already seen carl eugen's post referring to ticket 8615.
> > looks like this may be a regression ...  to answer your question, though,
> > i'm on a 2018 mini (i7); gpu is "Intel UHD Graphics 630", which should
> > support hardware decoding for hevc (and certainly for h264).
> Yes, I have, and I noticed it was about a dozen commits behind origin HEAD.
> So I pulled and rebuilt, and got the exact same error. Like decode was not even starting with vda or vt, encode still worked fine.
> Something interesting I noticed was when I ran ffmpeg -hwaccels it only showed videotoolbox once.
> It always listed it twice which I thought was weird, but only once now that it's not working.

I expect the two bugs to be unrelated.

> So does that mean it listed it once for decompression and once for compression via VideoToolbox?
> So it built without decode support but with encode support?

The ticket indicates decoding was broken (not removed in any way).

Carl Eugen

More information about the ffmpeg-user mailing list