[FFmpeg-user] Testing transcode speeds on Raspberry Pi 4

MediaMouth communque at gmail.com
Fri Apr 17 01:00:42 EEST 2020

> That's kind of wacky, how did you install ffmpeg?
> sudo apt-get install ffmpeg
Though it turns out it was pre-installed on the 2020-02-14 kernal v4.19 RPI 4 image <https://www.raspberrypi.org/downloads/raspbian/>

Also added 
> apt-get install libomxil-bellagio-bin
> sudo apt-get install libomxil-bellagio-bin

> The error apparently indicates insufficient resources (https://github.com/raspberrypi/userland/blob/a246147c21ae5be92ad1b85199b5b0bb447e0544/interface/vmcs_host/khronos/IL/OMX_Core.h#L142 <https://github.com/raspberrypi/userland/blob/a246147c21ae5be92ad1b85199b5b0bb447e0544/interface/vmcs_host/khronos/IL/OMX_Core.h#L142>) This was an RPi 4 right? 4B?

> How much memory did you split to video?
I was unaware of the option, so it was set to the default (64mb).  Thanks for the tip.
Just set it to the 512mb, re-booted and tested the speed again ( max for RPI according to the raspberrypi site <https://www.raspberrypi.org/documentation/configuration/config-txt/memory.md> ). Unfortunately, no improvement in the speed.

The same page above that specifies 512mb is the max, also specifies 1024mb is an option.  Tried that as well.  Still no speed boost..

> I thought it could do 4k encode in hardware, but maybe it was only decode. In any case I feel like you should fix that library mismatch warning if only as a cosmetic improvement, either reinstall from apt or some static build.
So maybe apt uninstall?

> I don't think there's much difference whether you specify -s or use scale filter if all you're doing in the end is scaling the frame size.
I actually don't necessarily need to scale the output, as long as I can control the bit rate.  It's just that FFmpeg returns an error without it... (according to the subsequent response by Carl, the reason is the hardware can't encode 4k.)

> Regards,
> Ted Park

More information about the ffmpeg-user mailing list