[FFmpeg-user] x264 0.155.2893 (very recent changes)

Reindl Harald h.reindl at thelounge.net
Thu Jan 11 12:51:54 EET 2018



Am 11.01.2018 um 11:44 schrieb Carl Eugen Hoyos:
>>>> Include the log file "ffbuild/config.log" produced by configure as this
>>>> will help solve the problem.
>>>
>>> Did you do this?
>>
>> did you *really* read the initial mail?
>> i can't include something which don't exist at all
>>
>> [builduser at buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
>> insgesamt 28K
>> -rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
>> -rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
>> -rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
>> -rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
>> -rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17 pkgconfig_generate.sh
>> -rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
> 
> This sounds like a serious bug (your original issue is easy to work-around):
> How can I reproduce this?

likely by just build last recent x264 to a non defualt location and try 
to link it static to ffmpeg

see rpm-specs and scripts how the snaphots get downloaded attached


[builduser at testserver:/rpmbuild/SPECS]$ rpmbuild -bb ffmpeg-latest.spec
Ausf├╝hrung(%prep): /bin/sh -e /var/tmp/rpm-tmp.z9KjMe
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd /home/builduser/rpmbuild/BUILD
+ rm -rf ffmpeg-20180111
+ /usr/bin/xz -dc /home/builduser/rpmbuild/SOURCES/ffmpeg-20180111.tar.xz
+ /usr/bin/tar -xof -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd ffmpeg-20180111
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Ausf├╝hrung(%build): /bin/sh -e /var/tmp/rpm-tmp.Wzc66h
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd ffmpeg-20180111
+ mkdir generic
+ pushd generic
~/rpmbuild/BUILD/ffmpeg-20180111/generic ~/rpmbuild/BUILD/ffmpeg-20180111
+ ../configure --prefix=/usr/local --bindir=/usr/local/bin 
--mandir=/usr/local/man '--extra-cflags=-I/usr/local/x264 -m64 -O2 -g0 
-mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge 
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions 
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2 
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math 
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops 
-fno-strict-aliasing -fuse-ld=gold -fuse-linker-plugin 
-Wa,--noexecstack' '--extra-ldflags=-I/usr/local/x264 -L/usr/local/x264 
-ldl -Wl,--as-needed -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -m64 -O2 
-g0 -mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge 
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions 
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2 
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math 
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops 
-fno-strict-aliasing -pie -fPIE -fuse-ld=gold -fuse-linker-plugin 
-Wa,--noexecstack' --ar=gcc-ar --ranlib=true --enable-nonfree 
--enable-gpl --enable-pic --enable-version3 --enable-libmp3lame 
--enable-libtheora --enable-libx264 --enable-libx265 --enable-libvpx 
--enable-openssl --enable-static --enable-runtime-cpudetect 
--disable-amd3dnow --disable-amd3dnowext --disable-avdevice 
--disable-debug --disable-devices --disable-ffplay --disable-ffprobe 
--disable-htmlpages --disable-hwaccels --disable-iconv 
--disable-libdc1394 --disable-libfreetype --disable-libgsm 
--disable-libopencore-amrnb --disable-libopencore-amrwb 
--disable-libopencv --disable-libopenjpeg --disable-libopus 
--disable-librtmp --disable-libspeex --disable-libvorbis 
--disable-libxvid --disable-podpages --disable-postproc 
--disable-protocol=gopher --disable-shared --disable-txtpages
ERROR: libx264 not found


If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "ffbuild/config.log" produced by configure as this 
will help
solve the problem.
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.Wzc66h (%build)


[builduser at testserver:/rpmbuild/SPECS]$ ls 
/rpmbuild/BUILD/ffmpeg-20180111/ffbuild/
insgesamt 28K
-rw-r--r-- 1 builduser builduser  829 2018-01-11 10:13 arch.mak
-rw-r--r-- 1 builduser builduser 5,0K 2018-01-11 10:13 common.mak
-rw-r--r-- 1 builduser builduser 3,7K 2018-01-11 10:13 library.mak
-rwxr-xr-x 1 builduser builduser  478 2018-01-11 10:13 libversion.sh
-rwxr-xr-x 1 builduser builduser 1,5K 2018-01-11 10:13 pkgconfig_generate.sh
-rwxr-xr-x 1 builduser builduser 1,9K 2018-01-11 10:13 version.sh
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpeg-latest.spec
Type: text/x-rpm-spec
Size: 9309 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180111/82a4d976/attachment.bin>
-------------- next part --------------
#!/usr/bin/bash

set -e

tmp=$(mktemp -d)

trap cleanup EXIT
cleanup() {
    set +e
    [ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
}

unset CDPATH
pwd=$(pwd)
date=$(date +%Y%m%d)
echo "$tmp"
cd "$tmp"

git clone git://git.videolan.org/ffmpeg.git 
mv ffmpeg ffmpeg-$date
cd ffmpeg-$date
pushd libswscale
popd
find . -type d -name .git -print0 | xargs -0r rm -rf
cd ..
tar Jcf "$pwd"/ffmpeg-$date.tar.xz ffmpeg-$date
cd - >/dev/null
-------------- next part --------------
A non-text attachment was scrubbed...
Name: x264-latest.spec
Type: text/x-rpm-spec
Size: 5092 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180111/82a4d976/attachment-0001.bin>
-------------- next part --------------
#!/usr/bin/bash

set -e

tmp=$(mktemp -d)

trap cleanup EXIT
cleanup() {
    set +e
    [ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
}

unset CDPATH
pwd=$(pwd)
git=$(date +%Y%m%d)

pushd "$tmp"
git clone git://git.videolan.org/x264.git x264-$git
pushd x264-$git
./version.sh .
find . -type d -name .git -print0 | xargs -0r rm -rf
popd
tar Jcf "$pwd"/x264-$git.tar.xz x264-$git
popd >/dev/null


More information about the ffmpeg-user mailing list