[FFmpeg-user] ffmpeg mingw compilation 8192 char limits windows 10

Erwan Douaille douailleerwan at gmail.com
Wed Dec 19 15:39:53 EET 2018


I´m trying to compile ffmpeg shared with mingw64 on Windows 10.
Here is the configure command:

    ./configure --arch=x86_64 --enable-shared --disable-static

Everything looks ok.
Then I make:

    mingw32-make.exe -j16

But I encounter this error:

    LD      libswresample/swresample-3.dll
    LD      libswscale/swscale-5.dll
    dlltool -m i386:x86-64 -d libswresample/swresample-3.def -l
libswresample/swresample.lib -D swresample-3.dll
    dlltool -m i386:x86-64 -d libswscale/swscale-5.def -l
libswscale/swscale.lib -D swscale-5.dll
    STRIP   libavcodec/x86/vp9itxfm.o
    GEN     libavcodec/libavcodec.ver
    EXTERN_PREFIX="" AR="ar" NM="nm -g" ./compat/windows/makedef
libavcodec/libavcodec.ver libavcodec/012v.o libavcodec/4xm.o
libavcodec/8bps.o libavcodec/8svx.o libavcodec/a64multienc.o
    ... // SKIP all .o files for stackoverflow
    libavcodec/y41pdec.o libavcodec/y41penc.o libavcodec/ylc.o
libavcodec/yop.o libavcodec/yuv4dec.o libavcodec/yuv4enc.o
libavcodec/zerocodec.o libavcodec/zmbv.o libavcodec/zmbvenc.o >
    Object does not exist: lib
    mingw32-make: *** [ffbuild/library.mak:102: libavcodec/avcodec-58.dll]
Error 1

As you can see Object does not exist: lib does not mean anything. After
some investigations it looks like this is due to cmd.exe 8129 character
limitation for parameters. I tried to set a different ComSpec value,
without success. I also tried to do some changes in library.mak Using a
file containing *.o files but I encounter many errors.

It looks like this is a known issue but nothing I tried works :

Any tips to fix it ?

Best regards,

Douaille Erwan <douaille.erwan at gmail.com>

More information about the ffmpeg-user mailing list