[FFmpeg-user] id3 tags not really removed?

Rodolfo Medina rodolfo.medina at gmail.com
Tue May 30 01:03:15 EEST 2017

Rodolfo Medina <rodolfo.medina at gmail.com> writes:

> Rodolfo Medina <rodolfo.medina at gmail.com> writes:
>> Gyan <gyandoshi at gmail.com> writes:
>>> Unless specified otherwise, ffmpeg will transcode streams. You have to add
>>> -c copy
>>>  to force stream copy (if the output format supports it). So,
>>> $ ffmpeg -i input.mp3 -c copy -metadata artist="Caterina Pontrandolfo
>>> Quartett" -metadata album="concerto di Fonte Avellana" -metadata
>>> genre="popular" -metadata composer="tradizione lucana" output.mp3
>> Great.  Many thanks.
> It works fine...  But now I want to modify, to change some of those id3 tags.
> Apparently, it is done with simply giving the above command once again, with
> values changed at my pleasure: when afterwards I run `ffmpeg -i' on the file,
> everything is fine and the values have changed as desired.  But when I read
> the file using the mp3 reader which is in my car, the old tags are still
> there...!  They have not changed at all!  How comes, and how to solve it?
> Thanks for any help,
> Rodolfo

... I also tried to remove all the tags with:

 $ ffmpeg -i input.mp3 -map 0:a -map_metadata -1 -c copy out.mp3

and then put them again, but the problem remains...


More information about the ffmpeg-user mailing list