[FFmpeg-user] ffmpeg using MediaCodec, avcodec_open2 says error code:-1 (0xffffffff) text: “Operation not permitted”

Miguel del Amor miguel.delamor at displaynote.com
Thu May 11 16:18:48 EEST 2017

Qt version: 5.7.1

ffmpeg version: n3.3

Android version: 5.1.1 ( but I've tried on some different devices )

I'm trying to use the Android API MediaCoded that have been supported by ffmpeg but while I try to open the codec I got "Operation not permitted" all times, I've tried some changes and I've tried to find examples without not luck.

This is what I'm doing

av_jni_set_java_vm(QAndroidJniEnvironment::javaVM(), NULL);


AVCodec *_codec(nullptr);
AVCodecContext *_codecContext(nullptr);

if (_codec == nullptr)
    _codec = avcodec_find_decoder_by_name("h264_mediacodec");

if (_codecContext == nullptr)
    _codecContext = avcodec_alloc_context3(_codec);

int ret = 0;
if( (ret = avcodec_open2(_codecContext, _codec, NULL)) < 0 ) {

    memset(str, 0, sizeof(str));
    av_strerror(ret, str, sizeof(str));

    qDebug("avcodec_open2 \"%s\" error[code:%d text:\"%s\"]",_codec->long_name, ret, str);

And I'm getting this output

avcodec_open2 "H.264 Android MediaCodec decoder" error[code:-1 text:"Operation not permitted"]

What I'm doing wrong?



Miguel del Amor Herrera

Engineering Manager


T: +34 868076105/868074570

Traperia 19 3º D Murcia

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OutlookEmoji-1477648663875_image001.png.png
Type: image/png
Size: 7037 bytes
Desc: OutlookEmoji-1477648663875_image001.png.png
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20170511/8766acdf/attachment.png>

More information about the ffmpeg-user mailing list