[FFmpeg-user] "Using AVStream.codec ... deprecated, use AVStream.codecpar instead" on output to wav

Carl Eugen Hoyos ceffmpeg at gmail.com
Fri Sep 30 12:06:31 EEST 2016

2016-09-30 10:53 GMT+02:00 Ashley Hooper <ashleyghooper at gmail.com>:
> I'm trying to convert an mp3 to wav for input to neroAacEnc as below. This
> has always worked in the past, but with the current version of
> ffmpeg/avconv in Debian Testing (version 3.1.3-1+b3) no longer does.

If this issue is not reproducible with current FFmpeg git head (the only
version supported here), you should report it to Debian.

> The command line I'm using is:
> ffmpeg -i "test.mp3" -f wav - | neroAacEnc -ignorelength -if - -q 0.25
> -of "test"

Whenever you ask for support here, please do not just provide a
command line but the command line you used together with the
complete, uncut console output.

Note that the wav format is not really suitable for piping (but if Nero
accepts it, I understand that you don't care) but if it worked in the
past, we would of course like to fix it.

Carl Eugen

More information about the ffmpeg-user mailing list