[FFmpeg-user] Could not write header for output file #0 (incorrect codec parameters ?):

juan carlos Rebate nerus492 at gmail.com
Thu Jun 23 17:31:04 CEST 2016

2016-06-22 21:33 GMT+02:00 juan carlos Rebate <nerus492 at gmail.com>:

> 2016-06-22 21:16 GMT+02:00 Cley Faye <cleyfaye at gmail.com>:
>> 2016-06-22 19:45 GMT+02:00 juan carlos Rebate <nerus492 at gmail.com>:
>> > the problem is in ffmpeg not know what else wants me to say, I have
>> > indicated the error, as I indicated all screen output with the error,
>> have
>> > not received any solution, if you want something specific let me know
>> >
>> ‚ÄčI, and other, pointed out that your command line was incorrect *and* that
>> your choice of codec/container was invalid for what you're trying to do.
>> Some provided *working* example.
>> There is no detailed explanation on the error code because it spells out
>> what's wrong:
>> > [mp4 @ 00000000028d5840] muxer does not support non seekable output
>> > Could not write header for output file #0 (incorrect codec parameters
>> ?):
>> It plain say "mp4 muxer does not support non seekable output". If you
>> insist on using a container that "does NOT support NON SEEKABLE output"
>> with a *non seekable* output such as a stream obviously you'll keep
>> getting
>> an error.
>> What I learned is that if google don't give anything useful with an error
>> message, there is two possibilities: you've discovered a new problem, or
>> you're doing something wrong. Seeing that ffmpeg is used in that exact
>> scenario by a lot of people, well... I'm not saying there is no bug in
>> ffmpeg but "take input X, output to Y" is one of the feature that works
>> fine.
>> Granted, I don't have the whole picture, but to fix what you posted in
>> this
>> thread, just changing the mp4 container to anything that support streaming
>> works fine, as said by others, as said by me, and as *showned* in a video.
>> I'm baffled why you keep saying "oh no there is no solution this program
>> is
>> clearly not working" when you've got many already.
>> As far as I'm concerned, this thread is done: you've given a bogus
>> command,
>> you've got answers as to what was wrong with it, and a working example.
>> I'm
>> afraid there's nothing more that can be done by random people there.
>> _______________________________________________
>> ffmpeg-user mailing list
>> ffmpeg-user at ffmpeg.org
>> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>> To unsubscribe, visit link above, or email
>> ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".
> then makes no sense to use ffmpeg, I tried to use flash and I can not do
> so, I tried to do it with webm and you can not do so
> Adobe has told me in an email that flash if it supports what I want using
> swf as container, but ffmpeg sends me the same error
I'm desperate, I have found that the order of commands does not matter, but
if I have come to the conclusion that there are two possibilities.
1 ffmpeg can not do what I need.
2 is missing some command syntax, I purchased a book which says that the order
of commands does not matter that the syntax is correct, I consulted with
adobe and tells me that flash can make streaming using RTMP protocol and
prococolo http, this book only has about streamin with webcam example thus
serves no purpose for me
Does anyone know how I can do to write the header?

More information about the ffmpeg-user mailing list