[FFmpeg-user] Compile FFmpeg with AAC support for windows

Ricardo Gonçalves ricardo.goncalves at appgeneration.com
Wed Sep 2 18:42:48 CEST 2015


I've been trying to add AAC decoding support to FFmpeg but so far I have
been unsuccessful.
I have followed the instructions here:
https://trac.ffmpeg.org/wiki/CompilationGuide/WinRT and added to the
configure command the options --enable-libfaac and --enable-nonfree.
As for the versions of the libraries I'm using they are:

FFmpegInterop  - the latest version (which has is accompanied by the FFmpeg
version that is compatible): https://github.com/Microsoft/FFmpegInterop
FAAC - also the latest: http://www.audiocoding.com/faac.html

I tried to build FAAC from the MSYS2 but I was unsuccessful so I tried to
build it from VS2015 where it was successful, creating both libfaac.dll and
libfaac.lib. However when I run the configuration command  I obtain this

link -APPCONTAINER WindowsApp.lib -nologo -libpath:ARGEADDRESSAWARE
-out:./ffconf.Np3dEkWD.exe ./ffconf.w1A1mudZ.o faac.lib
LINK : fatal error LNK1181: cannot open input file 'faac.lib'
ERROR: libfaac not found

I changed the file name from libfaac.lib to faac.lib,but no result. I added
the lib directory to the environment variables, but it doesn't seem to
detect the file and the same error persists, even tho the file is there.

Files (x86)\Windows Kits\NETFXSDK\4.6\lib\um\x86;;C:\Program Files
(x86)\Windows Kits\NETFXSDK\4.6\Lib\um\x86C:\faac-1.28\libfaac\DebugDLL;
Files (x86)\Windows Kits\NETFXSDK\4.6\Include\um;C:\faac-1.28\include;

I'm wondering if anyone has had any experience with this problem and could
help me bypass it.
Thank you,

More information about the ffmpeg-user mailing list