[FFmpeg-user] avfoundation on osx 10.7.5: issues with audio input

Thilo Borgmann thilo.borgmann at mail.de
Wed Mar 4 18:23:36 CET 2015


> [...]
> As a side note, I've modified 'configure' . I've removed the
> -framework CoreGraphics bits since ffmpeg wouldn't compile with those
> bits included. I also tried changing it to ApplicationServices which
> compiled, but resulted in the same 'audio format is not supported'
> error when I tried to capture audio. Anyone have any thoughts? I
> don't know enough objective-C to modify avfoundation.m to give a more
> descriptive error message but if anyone wants to point me in the
> right direction I'll gladly give it a whirl and try to capture any
> more details as to what's going wrong.

please apply both patches posted from Carl Eugen in this mail:


They might already solve both of your problems and will hit git HEAD soon.

If you still have issues with both patches applied, please open a ticket
on trac.ffmpeg.org.


More information about the ffmpeg-user mailing list