[FFmpeg-user] IVTC with pullup filter

Nicholas Robbins nickrobbins at yahoo.com
Wed Feb 11 21:21:57 CET 2015

> On Wednesday, February 11, 2015 1:34 PM, marcjn <windbreiz at gmail.com> wrote:

> > Carl Eugen Hoyos wrote
>>  marcjn 
>>   gmail.com> writes:>  I could submit sample and logIf you don't 
> submit
>>  them, help is extremely unlikely afaict.(This is of course not pullup
>>  related.)Carl
>>  Eugen_______________________________________________ffmpeg-user mailing
>>  list
>>  ffmpeg-user@
>>  http://ffmpeg.org/mailman/listinfo/ffmpeg-user
> I don't see my recent mails to the list posted here so I will try from my
> browser (I am new to this mail list format).I have been trying to convert a
> telecined clip (29.97 fps) to a progressive one (23.976 fps).The clip I am
> using for test purpose is here:
> https://dl.dropboxusercontent.com/u/71351606/TermSample2.mp4
> <https://dl.dropboxusercontent.com/u/71351606/TermSample2.mp4>  The sample
> contains a x.264 video stream and an AAC 2-channel audio stream.
> I first tried to use -vf pullup, fps=24000/1001:
> The log is  here
> <https://dl.dropboxusercontent.com/u/71351606/pullup_fps.log>  The result
> was a 23.976 fps clip, showing up as 'progressive' with MediaInfo, but 
> with
> 2 progressive frames, followed by 2 frames each blending 2 fields (combing).
> I also tried -vf pullup -r 24000/1001
> as some users mentioned that this worked for them:Here is the log:  here
> <https://dl.dropboxusercontent.com/u/71351606/pullup_rate.log>  The result
> was the same: 2 progressive frames followed by 2 blended ones.
> I then tried -vf fieldmatch,decimate:
> The log is  here
> <https://dl.dropboxusercontent.com/u/71351606/fieldmatch_decimate.log> 
> Different result here: most of the time, we have 3 progressive + 1 blended
> frame, but on occasion 2 progressive + 2 blended.I do hope someone knows how
> to make IVCT work under ffmpeg.Thanks.

I think your problem is that your media is not actually 29.97 fps.

ffprobe reports 28.97 fps, multiplying that by 4/5 gives 23.76

Try just -vf pullup,fps=23.176 no fps argument.

Worked here.


More information about the ffmpeg-user mailing list