[FFmpeg-user] concat images to h.264 movie not working

Roger Allen rallen at gmail.com
Tue Dec 8 07:33:06 CET 2015

I can confirm that putting the "-r 30" to just prior to the -i option works
well for me.  Thanks again, Moritz.

I will say that a 25Hz -> 30Hz resampling doesn't seem like it should drop
all but 2 frames.  But, that wasn't really what I wanted either.  I wanted
a straight 30Hz rate without resampling.

On Mon, Dec 7, 2015 at 5:29 PM, Marton Balint <cus at passwd.hu> wrote:
> Is this a regression?

In my opinion, this appears to be a regression.  This worked as I expected
(or close enough) with ffmpeg 1.1.3 on my Mac.

> Does this work OK if duration is specified in the concat file for each

It appears to work without any DTS/PTS errors if I specify 'duration
0.03333333333' after each file statment.

> I have a feeling that the concat demuxer never worked well with static
images and unknown duration.

I see 1.1.3 working.  I'm new around here, but it seems overly pedantic to
force users to add a constant duration value in between every line for such
a simple case.


More information about the ffmpeg-user mailing list