[FFmpeg-user] V4L2 recording results in invalid data & buffer still owned errors.

Louis Rossmann l.a.rossmann at gmail.com
Mon Sep 15 15:42:37 CEST 2014

On Sat, Sep 6, 2014 at 9:36 AM, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:

> Louis Rossmann <l.a.rossmann <at> gmail.com> writes:
> > So that messed up configure line is not Gentoo's
> > fault, but all mine. :(
> Then please reconfigure with "./configure --enable-gpl"
> and add the external libraries you need, do NOT add any
> --disable-* flags and do NOT add any --extra-cflags /
> --extra-ldflags except those needed for library detection.
> Your current executable is intentionally slow.
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

I've done everything I can with my executable, however, the problem

If I run a recording, it works. if I stop the recording, there is little I
can do short of reboot the system to record a second video using the V4L2
device. I've tried on an Ubuntu desktop and a Gentoo laptop. Do you have
any suggestions? Kernel 3.14 was a quick fix but sadly that did not last
long. :(

More information about the ffmpeg-user mailing list