[FFmpeg-user] ffmpeg configuration issue on Mac OSX

Kimio Miyamura xanadu at apost.plala.or.jp
Sat Sep 6 19:34:21 CEST 2014

> 2014/09/05 11:54PM Shiva Krishna Kanike <shivakrishna <at> aetherpal.com> Wrote:
> When I run below command on my Mac's Terminal, it always throws error. I tired lot of ways to fix it, but I failed each time.
> "./configure --prefix=/usr/local --enable-gpl --enable-nonfree --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid"

Your confine.log says that ffmpeg can't find out libass.  
This is because of pkg-config is not installed or because of libass is not installed.
I also find out "WARNING: pkg-config not found, library detection may fail." message in your config.log.  So may be you don't install pkg-config yet.  
You have to install pkg-config first, then install all library which you'll be enable with ffmpeg configure option.  

I have a Japanese version of step by step ffmpeg compile guide.  I have confirmed that this page can be translate if you use Google Chrome.  The URL is:  http://xanadu62.blogspot.com/2013/10/ffmpeg.html

> When I run "brew install ffmpeg" command on my Mac's Terminal, it says "Warning: ffmpeg-2.3.3 already installed, it's just not linked".

I dislike Home brew.  But It means what it says.  Haven't you installed ffmpeg via Home brew before?
if you'd like to uninstall ffmpeg which is installed with Home brew, Just type "brew uninstall ffmpeg" then hit return.  

// Miya

More information about the ffmpeg-user mailing list