[FFmpeg-user] ffmpeg configuration issue on Mac OSX

Shiva Krishna Kanike shivakrishna at aetherpal.com
Fri Sep 5 16:54:49 CEST 2014


I am trying to use ffmpeg to compress my videos on iPhone programmatically, I found a link to configure ffmpeg on your site, "https://trac.ffmpeg.org/wiki/CompilationGuide/MacOSX".
But I am facing issue while configuring ffmpeg on my Mac, any help is greatly appreciated.

When I run below command on my Mac's Terminal, it always throws error. I tired lot of ways to fix it, but I failed each time.

"./configure --prefix=/usr/local --enable-gpl --enable-nonfree --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid"

When I run "brew install ffmpeg" command on my Mac's Terminal, it says "Warning: ffmpeg-2.3.3 already installed, it's just not linked".

Please find the "config.log" file for your reference.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 276080 bytes
Desc: config.log
URL: <https://ffmpeg.org/pipermail/ffmpeg-user/attachments/20140905/5beeff29/attachment.obj>

More information about the ffmpeg-user mailing list