[FFmpeg-user] Problems decoding h.264 video

Oliver Fromme oliver at fromme.com
Thu Jul 31 18:31:59 CEST 2014

Tom Evans wrote:
 > On Tue, Jul 29, 2014 at 7:28 PM, Oliver Fromme <oliver at fromme.com> wrote:
 > > [...]
 > > I found out that the "official" FreeBSD port of ffmpeg works.
 > > However, that's not the current git version ...  I'd like to
 > > work with the current git version.
 > > 
 > > So I tried to look at the FreeBSD port in order to find out
 > > what it does differently, but without any luck so far.  :-(
 > > I'm basically using the same configure options.
 > Use either clang or gcc 4.6+ from ports and your errors will disappear.

Yes, indeed, thanks for the hint.

But I don't understand why the official FreeBSD port works.
It does *not* depend on a newer gcc version, and in fact the
start-up message shows that it is build with the stock old
FreeBSD compiler (4.2.1):

ffmpeg version 2.2.4 Copyright (c) 2000-2014 the FFmpeg developers
  built on Jul 29 2014 20:18:45 with gcc 4.2.1 (GCC) 20070831 patched [FeeBSD]

I noticed that the port depends on a newer version of the
binutils, but I'm not sure what's required to build ffmpeg
with those binutils.  The port apparently sets $COMPILER_PATH
to /usr/local/bin, but when I do that with the git sources,
it still doesn't work.

(Of course, the problem is solved, I'll just use the newer gcc,
but still I would like to know why the port works with the old
gcc, and how to reproduce that when compiling the git sources

Best regards

``We are all but compressed light'' (Albert Einstein)

More information about the ffmpeg-user mailing list