[FFmpeg-user] ffmpeg -ss start-time issue

richard heade richard.heade at gmail.com
Thu Apr 3 00:19:42 CEST 2014

I have tried a number of variations on generating timestamps on the
video, like

ffmpeg -i HiDef.mpg -vf
drawtext="fontfile=/usr/share/fonts/truetype/DejaVuSans.ttf: \
                                text='\%T %D': x=10: y=10: fontsize=24:
fontcolor=white" \
                                                        -vcodec copy
-acodec copy xgen_white.mp4

(I also tried "fontcolor=black")


ffmpeg -i HiDef.mpg -vf
    box=1:text='%T %D':x=(w-text_w-5):y=(h-text_h-5)" -vcodec copy
-acodec copy timestamp.avi

and I haven't been able to detect any timestamps on the video.

On 03/27/2014 07:31 AM, Tom Horsley wrote:
> On Thu, 27 Mar 2014 07:07:31 -0700
> richard heade wrote:
>> If
>> they are incompatible is there another way, compatible with ffmpeg, to
>> get the frame count, elapsed time, and frame type from a video?
> I've never found any two video editors that agreed on timestamps :-(.
> I use the big hammer of generating a small version of the video
> with the timestamps printed on each frame by ffmpeg so I'm
> sure the same version of ffmpeg will believe the same timestamp:
> http://home.comcast.net/~tomhorsley/game/ffmpeg.html#generatetimestamps
> I can then play that video and pause to pick timestamps off
> the image.

More information about the ffmpeg-user mailing list