[FFmpeg-user] background process getting terminated

focus television focustelev at gmail.com
Mon Jul 23 13:31:36 CEST 2012

    On 21-Jul-12 10:47 AM, Nicolas George wrote:
    Le quartidi 4 thermidor, an CCXX, focus television a écrit :
    I am using (nohup ffmpeg -i "rtmp://localhost:1935/base2

   nohup is a stupid hack that does not really work. You should use 
setsid to
   really detach the process from the controlling tty.

    Playpath=mam1.stream  live=1" -vcodec copy -b:v 700k -c:a copy -f
    flv rtmp://localhost/mal1/mam1 ;)&

   You need to prevent ffmpeg from reading on its standard input. For that,
   either add "  /dev/null" or use the new -nostdin option.

    But after some time it is getting terminated. Not sure if it is due
    to the bug nohup file or because i close the terminal session.
    I tried screen and background but still the process terminates after
    some hours.
    Not sure what is wrong.
    I dont want the log file and want to run it in background so that it
    doesnt get terminated when i close ssh.

   Maybe you do not want the log file, but if it does not work, you need 
it. If
   The advice above do not fix that problem, be sure to read the errors 
in the
   log. You can consider discarding the log once you are sure everything 
   fine (but even so, I do not advise to).


Hi Nick & others,
i tried
  (setsid ffmpeg -i "rtmp:// 
Playpath=movi.stream live=1" -vcodec copy -b:v 700k -c:a copy  -f flv 
But still it gets  terminated. What i feel is that some times the source 
rtmp:// (changed the ip) doesnt send data or 
there is a delay
and due to which the process gets closed.
It my guess.. I have to restart the process alwatys after 1-2 hours.
I have 10 streams like this line pasted in an sh file. Some terminate 
and some run after 2 hours.. Thats why i assumed.

More information about the ffmpeg-user mailing list