[FFmpeg-user] Compiling failure

Alexandre Schenberg ale.schenberg at gmail.com
Sat Jul 7 11:20:20 CEST 2012

It worked. Also, I downloaded the newest version and just saying
make=V1 work there.

However, in both cases, after a good time of compilation, I get this:

"gcc  -o doc/print_options doc/print_options.o -lm
doc/print_options format > doc/avoptions_format.texi
doc/print_options codec > doc/avoptions_codec.texi
awk '/^@(verbatim)?include/ { printf "doc/ffmpeg.html: doc/%s\n", $2
}' <doc/ffmpeg.texi >doc/ffmpeg.html.d
texi2html -I doc -monolithic --init-file ./doc/t2h.init --output
doc/ffmpeg.html doc/ffmpeg.texi
Unknown option: init-file
Try 'texi2html -help' for usage instructions.
make: *** [doc/ffmpeg.html] Error 2"

2012/7/6, Mike Scheutzow <mike.scheutzow at alcatel-lucent.com>:
> Alexandre Schenberg wrote:
>> Yes, my make verson is 3.80.
>> I tried make V=1. I started to compile, but after a few seconds it
>> showed:
>> "In file included from libavdevice/v4l.c:40:
>> /usr/include/linux/videodev.h:55: error: syntax error before "ulong"
>> /usr/include/linux/videodev.h:71: error: syntax error before '}' token
>> libavdevice/v4l.c: In function `grab_read_header':
>> libavdevice/v4l.c:84: error: storage size of `tuner' isn't known
>> libavdevice/v4l.c:92: warning: `time_base' is deprecated (declared at
>> libavformat/avformat.h:350)
>> libavdevice/v4l.c:93: warning: `time_base' is deprecated (declared at
>> libavformat/avformat.h:350)
>> libavdevice/v4l.c:96: warning: `time_base' is deprecated (declared at
>> libavformat/avformat.h:350)
>> libavdevice/v4l.c:98: warning: `width' is deprecated (declared at
>> libavformat/avformat.h:353)
>> libavdevice/v4l.c:99: warning: `height' is deprecated (declared at
>> libavformat/avformat.h:354)
>> libavdevice/v4l.c:136: warning: `pix_fmt' is deprecated (declared at
>> libavformat/avformat.h:355)
>> libavdevice/v4l.c:144: error: invalid application of `sizeof' to an
>> incomplete type
>> libavdevice/v4l.c:146: error: invalid application of `sizeof' to an
>> incomplete type
>> libavdevice/v4l.c:84: warning: unused variable `tuner'
>> make: *** [libavdevice/v4l.o] Error 1"
>> Any possible solution? Anyway, time to get a newer make, right?
> This error is not caused by make. The problem is either old or missing
> .h files in /usr/include.
> As an experiment, you could disable the compiling of all these avdevices
> (used for hardware i/o mostly):
> ./configure --disable-indevs --disable-outdevs
> make V=1
> To see all the available configure options:
> ./configure --help | more
> Mike Scheutzow
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list