[FFmpeg-user] FFMPEG unable to receive UDP stream

Varun Ganesh vganesh2 at ncsu.edu
Thu Nov 24 06:07:56 CET 2011


I am sorry for sending the mail incorrectly. I am resending it properly.

I want to receive a UDP stream, transcode it and send it out to another
host. I have setup a streaming media server using vlc.

My machine IP is I setup the vlc to stream on udp://
> port 1234. I tried receiving the stream on the same machine
> using the command
> ffmpeg -i udp://  -f mpegts -vcodec mpeg4 -acodec mp2
> -ac 2 -ab 128k -s 720x432 -r 30 -re -b 2000k -threads 2 udp://

I have configured a client to listen on port 8005 to receive the stream on
the second machine. But the ffmpeg doesn't accept the first connection. I
was able to use a separate vlc client to receive the same on the host
I also tried it to send a file locally saved on the machine using
 ffmpeg -i filename  -f mpegts -vcodec mpeg4 -acodec mp2 -ac 2 -ab 128k -s
720x432 -r 30 -re -b 2000k -threads 2 udp://
and was able to successfully receive it on the second machine. How can I
get FFMPEG to listen and receive the UDP stream from the VLC server?

Varun Ganesh

More information about the ffmpeg-user mailing list