[FFmpeg-user] Using the "select" filter

Tim Nicholson tim.nicholson at bbc.co.uk
Thu Nov 17 12:19:48 CET 2011

The examples of using the select filter given at:-


suggest, for example,

# select only I-frames

However when I tried this I got an error.

ffmpeg -i in.mp4 -vf "select='eq(pict_type\,I)', showinfo" -f mp4 -y 
Missing ')' or too many args in 'eq(pict_type\,I)'

Removing the "\" which I assume is there to "escape" the comma solved 
the problem, thus:-

ffmpeg -i in.mp4 -vf "select='eq(pict_type,I)', showinfo" -f mp4 -y 

This looks like a small error in the docs.


This e-mail (and any attachments) is confidential and may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in error, please delete it from your system.
Do not use, copy or disclose the information in any way nor act in reliance on it and notify the sender immediately.
Please note that the BBC monitors e-mails sent or received.
Further communication will signify your consent to this.

More information about the ffmpeg-user mailing list