[FFmpeg-user] trouble with -vcodec copy

Carl Eugen Hoyos cehoyos at ag.or.at
Thu Nov 10 16:11:49 CET 2011

Arlo Leach <lists <at> arlomedia.com> writes:

> Unfortunately I'm still getting the same result -- no video track if I use
> -vcodec copy.
> Actually, I've been testing with a short source video (15 seconds) and 
> extracted sample (3-4 seconds). I just tried with a longer source video (180
> seconds) and sample (30 seconds) and my sample clip has a video track, but
> the first six seconds of it are blank (I just see the background color of the
> video player). The audio plays correctly from the start, but the video
> doesn't begin until six seconds into the clip.

Could you upload a sample to http://www.datafilehost.com/ and post the download
link here?

You may have found a new feature that allows libavcodec not to output initial
H264 frames that cannot be decoded (because the stream does not start at gop
boundary), but that cannot be the problem you have seen with the old FFmpeg

Carl Eugen

More information about the ffmpeg-user mailing list