[FFmpeg-user] Blue Cherry PV-143 (BT878 Chipset) not working!

Mike Carambat mcaramb at rocketmail.com
Tue Nov 1 15:36:02 CET 2011

Anyone have a working command line for the Blue Cherry PV-143 (BT878 Chipset) capture card? 

It's a rather standard chipset for linux v4l based systems, and should work well, but I keep getting ioctl errors when issuing the following simplified command:

ffmpeg -an -f video4linux2 -i /dev/video0 test.avi

I don't believe this card has any type of hardware compressor, and simply outputs raw YUV video. I can query the card with v4l2-ctl and I've got all the specifics on size, pixel-type, fps, etc. I tried verbatim specifying these details before in the command line, but it didn't help. I also tried using -vcodec rawvideo. No dice.

Also, when doing:

ffplay -f video4linux2 /dev/video0

I get the same ioctl error, but I can see in the error message that it correctly detected all the aforementioned specifics and applied them automatically. So the card is being seen, read and configured, but the data stream is coming across as unusable.

I apologize for not having the exact error in front of me, but won't be back at that computer until later in the day. I'm posting this from memory, so I might have some ammunition to return with this evening. I'm running Ubuntu Server 11.10 with the latest standard apt installation package for ffmpeg (0.7.2-4:0.7.2-1ubuntu1)

Thanks for any advice


More information about the ffmpeg-user mailing list