[FFmpeg-user] ffmpeg -acodec problem

Nenad Lukic lord_nenad at yahoo.com
Fri May 6 20:19:35 CEST 2011


I'm Nenad Lukic, php developer, I recently start dealing with ffmpeg, and I have serious problems with it...
So if you are a expert, and I'm just a beginner I will really appreciate your help.

Here is the problem:

I'm trying to make conversions for html5 videos, converting to mp4, webm, ogg/ogv formats.
First I had version 0.6.0 that didn't had webm installed, so I ask 
operators to update that version, and they did, and after that, none of 
the conversions didn't work...
Then I hire someone, to make that... Then that man delete ffmpeg and 
install new copy... BUT, in php information page version is 0.6.3, and 
when I run ffmpeg -version I get 0.7rc-1 version...

Here is the real problem now:

mp4 and webm are converting okay, because their default codecs are ones 
used for html5, but with ogg/ogv default audio format is flac, that 
can't be viewed in browsers.
That why I have videos without sound.
But, problem is that when I try to use sound codecs -acodec no matter what codec I try to use, it doesn't work.
I tried with 10 different audio codecs, and only 3 of them ware creating files, and 0 bytes files.

So I can't do conversions, and I don't know why is this...

Can someone help me?
Tell me what to do, how this can be handled, tell me what is the problem, anything...

Thank you! I will really appreciate your help!

Best regards,
Nenad Lukic 

More information about the ffmpeg-user mailing list