[FFmpeg-user] problem compiling ffmpeg 0.8.2

Jaroslav huglester at gmail.com
Fri Dec 30 01:31:36 CET 2011

Hello guys,

have you solved this problem yet?
I can't seem to find the solution. Tried so many variants that I can think
of.. with still no luck.
My error is similar..

Here are the instalation options:

# x264
cd  $HOME
git clone git://git.videolan.org/x264
cd x264
./configure --enable-shared --enable-pic
# I have tried without --enable-pic, but someone on the internet said it
helped him)
sudo checkinstall --pkgname=x264 --default --pkgversion="3:$(./version.sh |
    awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes

#Install libvpx
cd  $HOME
git clone http://git.chromium.org/webm/libvpx.git
cd libvpx
./configure --enable-shared
sudo checkinstall --pkgname=libvpx --pkgversion="$(date +%Y%m%d%H%M)-git"
--backup=no \
    --default --deldoc=yes

# Install FFmpeg
cd  $HOME
git clone git://github.com/FFmpeg/FFmpeg.git ffmpeg
cd ffmpeg
./configure --enable-gpl --enable-libfaac --enable-libmp3lame
--enable-libopencore-amrnb \
    --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis
--enable-libvpx \
    --enable-libx264 --enable-shared --enable-nonfree --enable-postproc
--enable-version3 --enable-x11grab

at this step I get the error:
LD      libavutil/libavutil.so.51
LD      libavcodec/libavcodec.so.53
relocation R_X86_64_32 against `.rodata' can not be used when making a
shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-linux-gnu/4.4.5/../../../../lib/libvorbisenc.a: could
not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libavcodec/libavcodec.so.53] Error 1

Any help is greatly appreciated...
I'm running Debian Squeeze, 64 bit version

Thank you in advance!

More information about the ffmpeg-user mailing list