[FFmpeg-user] Capturing from DVB-T card

Heiko Baums lists at baums-on-web.de
Wed Dec 21 15:20:59 CET 2011


I tried to capture a VHS-Video with ffmpeg but only got a black picture
while the sound was captured correctly.

I tried it with these commands:

ffmpeg -f alsa -ac 2 -i plughw:0 -f video4linux2 -i /dev/video0

ffmpeg -f alsa -ac 2 -ar 48000 -i plughw:0 -f video4linux2 -pix_fmt
yuv422p -s 768x576 -r 30000/1001 -i/dev/video0 -pix_fmt yuv422p -vcodec
huffyuv -vsync 2 -aspect 4:3 -f avi -s 768x576 -r 30000/1001 -y

I'm not sure if this is the problem, but I have a Terratec Cinergy 1400
DVB-T with a cx88 chip. It has a combined S-Video and Composite input.
So for v4l2 there can be selected three video sources (DVB-T, S-Video
and Composite) of which I need the Composite source.

man ffmpeg says:
"Note that you must activate the right video source and channel before
launching ffmpeg with any TV viewer such as xawtv
("http://linux.bytesex.org/xawtv/") by Gerd Knorr."

The problem is that the source can only be set for the particular
application but not system wide. So either the application saves the
default by itself or the selection is lost. It defaults to DVB-T. And
while having xawtv or tvtime running it's not possible to capture with
ffmpeg because the device is busy.

Is there a way to handle this with ffmpeg or should I file a bug report
or a feature request? Or am I missing anything or am I doing anything
else wrong?

It would be nice if someone could help me.


More information about the ffmpeg-user mailing list