[FFmpeg-user] External UVC Camera Video Streaming/Image Capturing using ffmpeg

s.rawat imsaurabhrawat at gmail.com
Mon Dec 12 07:58:10 CET 2011

I tried replcing this line with the line below in the build.sh
  # FLAGS="$FLAGS --disable-everything --enable-indevs

   FLAGS="$FLAGS --enable-indevs --enable-protocol=file"
but it gave this error :

ERROR: libvpx decoder version must be >=0.9.1

i tried installing the dev package for libvpx from the synaptic maager, but
still the same.Though I could see

 in the lib directory
libvpx.so.0.9.5 is defintely present and which is certainly > =0.9.1 , then
Y I am getting this error.
Any clue on this ?


"..pain is temporary.....quitting lasts forever......"

On Sat, Dec 10, 2011 at 7:43 PM, Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:

> s.rawat <imsaurabhrawat <at> gmail.com> writes:
> > ffmpeg -y -t 25 -f video4linux2 -r 15 -s 320*240 -pix_fmt yuyv422 -i
> >  /dev/video1 -an -f avi Test_QVGA1.avi
> >
> > But I am the following output/error(see in *Bold* at last) -->
> >
> > FFmpeg version UNKNOWN, Copyright (c) 2000-2010 the FFmpeg developers
> This is old, please use current git head, see
> http://ffmpeg.org/download.html
> > Requested output format 'avi' is not a suitable output format
> > ioctl(VIDIOC_QBUF)
> You specified "--disable-everything" to disable the avi muxer, so it does
> not
> work. I suggest you first try whatever you want to achieve with an
> as-short-as-possible configure line (without --disable-everything and if
> possible with static libraries), if it works, add --disable-everything and
> the
> necessary --enable options (and use --enable-shared if necessary).
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> ffmpeg-user at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user

More information about the ffmpeg-user mailing list