[FFmpeg-user] SIGSEGV when streaming to FFserver

Maxime Poulin maxpoulin64 at gmail.com
Thu Apr 7 03:13:52 CEST 2011

(This is my first message to any of the ffmpeg's mailing lists, please 
correct me if I'm doing wrong!)


I compiled FFmpeg a few times this week, trying to get it stream to 
FFserver, without any success. FFmpeg crashes as soon as it starts 
sending data to the server (which always receive 4149 bytes of data 
before the client crashes).

I am using the latest Git version as of now (git-N-28846-g02fd687) 
compiled using these instructions: 

This configuration worked before, but I changed my server and now my 
computer too, so I had to recompile FFmpeg on both of them. The server 
looks to work fine, and the local FFmpeg too. I can encode anything to 
anything, it works. But as soon as I try to send the data to FFserver, 
either on my local PC or on my server, I get a Segmentation Fault.

Here is the command I launch, which worked without problems before:

$ ffmpeg -f x11grab -r 60 -s 1920x1080 -i :0 -f alsa -ac 2 -i pulse 

As I said, I tried to update it and compile it a few times, but I didn't 
have any success, so I'm posting here next to the advice of someone on 
the IRC channel.

I attached a gdb log (223 lines), as indicated on the bug report page of 
the site.

Thanks in advance!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpeg-gdb.log
Type: text/x-log
Size: 13734 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20110406/c3cd5476/attachment.bin>

More information about the ffmpeg-user mailing list