[FFmpeg-user] FFmpeg configure script, iOS 4.3, XCode 3.2.6

Brent Murata brent at thegoodnite.com
Sat Apr 2 02:46:32 CEST 2011


I'm having problems with the FFmpeg configure scripts, iOS 4.3, and XCode
3.2.6.  I am a novice when it comes to gcc, so please forgive my questions.
 FYI, it seems that iOS 4.1, XCode 3.2.6 works ok.

I've tried the built in configure scripts without success.  At the command
prompt I enter:

--cc=/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc --as='
--enable-cross-compile --target-os=darwin --cpu=arm1176jzf-s --arch=arm
--extra-cflags='-arch armv6' --extra-ldflags='-arch armv6'

I have the FFmpeg git snapshot from 3/31/2011.

I've placed the gas-preprocessor.pl file in /usr/local/bin/

The error message is:  ld: file not found: /usr/lib/system/libcache.dylib
for architecture armv6

Config.log is attached.

I've read online that when using version 3.2.6 and version 4.0 of XCode we
should be using -isysroot instead of --sysroot.  I tried this without

Any advice / help would be much appreciated.

Brent Murata
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 71639 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20110401/719b9dcd/attachment-0001.obj>

More information about the ffmpeg-user mailing list