[FFmpeg-soc] expand filter (alternative to pad syntax)
Diego Biurrun
diego at biurrun.de
Sat May 10 09:38:04 CEST 2008
On Sat, May 10, 2008 at 12:57:53PM +0900, Ryo Hirafuji wrote:
> Here is a patch.
> It includes changes of allfilters.c and Makefile.
>
> --- allfilters.c (revision 2168)
> +++ allfilters.c (working copy)
> @@ -50,6 +50,7 @@
> REGISTER_FILTER(SPLIT,split,vf);
> REGISTER_FILTER(TRANSPOSE,transpose,vf);
> REGISTER_FILTER(VFLIP,vflip,vf);
> + REGISTER_FILTER(EXPAND,expand,vf);
Add this in alphabetical order.
>
> REGISTER_FILTER(MOVIE,movie,vsrc);
> }
> Index: vf_expand.c
> ===================================================================
> --- vf_expand.c (revision 0)
> +++ vf_expand.c (revision 0)
> @@ -0,0 +1,317 @@
> +
> + int last = 0;
> + int i;
> + int arg_cnt = 0;
These declarations could be merged.
> + for(i=0;i<h;i++){
some spacing could make these for loops more readable.
> --- Makefile (revision 2168)
> +++ Makefile (working copy)
> @@ -28,6 +28,7 @@
> OBJS-$(CONFIG_SPLIT_FILTER) += vf_split.o
> OBJS-$(CONFIG_TRANSPOSE_FILTER) += vf_transpose.o
> OBJS-$(CONFIG_VFLIP_FILTER) += vf_vflip.o
> +OBJS-$(CONFIG_EXPAND_FILTER) += vf_expand.o
alphabetical order here as well please.
Diego
More information about the FFmpeg-soc
mailing list