[FFmpeg-soc] [soc]: r1773 - in libavfilter: Makefile allfilters.h avfilter.c vf_rot90.c

Diego Biurrun diego at biurrun.de
Sun Jan 6 22:17:51 CET 2008


On Sun, Jan 06, 2008 at 06:07:04PM +0100, Vitor Sessak wrote:
> 
> Michael Niedermayer wrote:
> > On Sun, Jan 06, 2008 at 02:19:12PM +0100, vitor wrote:
> >>
> >> Log:
> >> 90 degrees counter-clockwise rotation filter
> > 
> > [...]
> > 
> >> +static void draw_slice(AVFilterLink *link, int y, int h)
> >> +{
> >> +    RotContext *rot = link->dst->priv;
> >> +    AVFilterPicRef *in  = link->cur_pic;
> >> +    AVFilterPicRef *out = link->dst->outputs[0]->outpic;
> >> +    int i, j, plane;
> >> +
> >> +    /* luma plane */
> >> +    for(i = y; i < h; i ++)
> >> +        for(j = 0; j < link->w; j ++)
> >> +            *(out->data[0] +   j *out->linesize[0] + i) =
> >> +                *(in->data[0]+ i * in->linesize[0] + j);
> > 
> > this looks more like transpose, that is
> > A   B       A   C
> >         ->
> > C   D       B   D
> > 
> > instead of 90° ccw rotate:
> > 
> > A   B       B   D
> >         ->
> > C   D       A   C
> 
> Agreed, renamed.

Maybe you can rename it to vf_transpose instead of vf_trans?  I don't
immediately think of transposing when hearing trans...

Diego



More information about the FFmpeg-soc mailing list