[FFmpeg-soc] [soc]: r3504 - mlp/mlpenc.c
ramiro
subversion at mplayerhq.hu
Thu Aug 21 04:48:14 CEST 2008
Author: ramiro
Date: Thu Aug 21 04:48:13 2008
New Revision: 3504
Log:
Rename restart_frame to clear_filter, since that what it's used for now,
independent of it being a restart_frame or not.
Modified:
mlp/mlpenc.c
Modified: mlp/mlpenc.c
==============================================================================
--- mlp/mlpenc.c (original)
+++ mlp/mlpenc.c Thu Aug 21 04:48:13 2008
@@ -694,12 +694,11 @@ static void determine_quant_step_size(ML
*/
static void set_filter_params(MLPEncodeContext *ctx,
unsigned int channel, unsigned int filter,
- int restart_frame)
+ int clear_filter)
{
FilterParams *fp = &ctx->channel_params[channel].filter_params[filter];
- /* Restart frames must not depend on filter state from previous frames. */
- if (restart_frame) {
+ if (clear_filter) {
fp->order = 0;
return;
}
More information about the FFmpeg-soc
mailing list