[FFmpeg-devel] [PATCH v4 4/4] lavf: Add documentation for private "Context" classes
Andreas Rheinhardt
andreas.rheinhardt at outlook.com
Wed May 22 18:24:36 EEST 2024
Andrew Sayers:
> Doxygen thinks any text like "Context for foo" is a link to a struct called "Context".
> Add a description and a better link, to avoid confusing readers.
> ---
> libavformat/async.c | 3 +++
> libavformat/cache.c | 3 +++
> 2 files changed, 6 insertions(+)
>
> diff --git a/libavformat/async.c b/libavformat/async.c
> index e096b0bc6f..3c28d418ae 100644
> --- a/libavformat/async.c
> +++ b/libavformat/async.c
> @@ -53,6 +53,9 @@ typedef struct RingBuffer
> int read_pos;
> } RingBuffer;
>
> +/**
> + * @brief @ref md_doc_2context "Context" for testing async
> + */
> typedef struct Context {
> AVClass *class;
> URLContext *inner;
> diff --git a/libavformat/cache.c b/libavformat/cache.c
> index 5f78adba9d..3cc0edec82 100644
> --- a/libavformat/cache.c
> +++ b/libavformat/cache.c
> @@ -52,6 +52,9 @@ typedef struct CacheEntry {
> int size;
> } CacheEntry;
>
> +/**
> + * @brief @ref md_doc_2context "Context" for a cache
> + */
> typedef struct Context {
> AVClass *class;
> int fd;
These structures should be renamed instead of adding these comments
(which are pointless for internal developers). I just sent a patch for that.
Thanks for pointing out the issue.
- Andreas
More information about the ffmpeg-devel
mailing list