[FFmpeg-devel] [PATCH 05/13] avformat/amr: Move write_header closer to muxer definition
Andreas Rheinhardt
andreas.rheinhardt at outlook.com
Wed Mar 20 04:12:48 EET 2024
Avoids one #if.
Signed-off-by: Andreas Rheinhardt <andreas.rheinhardt at outlook.com>
---
libavformat/amr.c | 32 +++++++++++++++-----------------
1 file changed, 15 insertions(+), 17 deletions(-)
diff --git a/libavformat/amr.c b/libavformat/amr.c
index 85815e8675..1b80810302 100644
--- a/libavformat/amr.c
+++ b/libavformat/amr.c
@@ -51,23 +51,6 @@ static const uint8_t amrwb_packed_size[16] = {
18, 24, 33, 37, 41, 47, 51, 59, 61, 6, 1, 1, 1, 1, 1, 1
};
-#if CONFIG_AMR_MUXER
-static int amr_write_header(AVFormatContext *s)
-{
- AVIOContext *pb = s->pb;
- AVCodecParameters *par = s->streams[0]->codecpar;
-
- if (par->codec_id == AV_CODEC_ID_AMR_NB) {
- avio_write(pb, AMR_header, sizeof(AMR_header)); /* magic number */
- } else if (par->codec_id == AV_CODEC_ID_AMR_WB) {
- avio_write(pb, AMRWB_header, sizeof(AMRWB_header)); /* magic number */
- } else {
- return -1;
- }
- return 0;
-}
-#endif /* CONFIG_AMR_MUXER */
-
#if CONFIG_AMR_DEMUXER
static int amr_probe(const AVProbeData *p)
{
@@ -268,6 +251,21 @@ const FFInputFormat ff_amrwb_demuxer = {
#endif
#if CONFIG_AMR_MUXER
+static int amr_write_header(AVFormatContext *s)
+{
+ AVIOContext *pb = s->pb;
+ AVCodecParameters *par = s->streams[0]->codecpar;
+
+ if (par->codec_id == AV_CODEC_ID_AMR_NB) {
+ avio_write(pb, AMR_header, sizeof(AMR_header)); /* magic number */
+ } else if (par->codec_id == AV_CODEC_ID_AMR_WB) {
+ avio_write(pb, AMRWB_header, sizeof(AMRWB_header)); /* magic number */
+ } else {
+ return -1;
+ }
+ return 0;
+}
+
const FFOutputFormat ff_amr_muxer = {
.p.name = "amr",
.p.long_name = NULL_IF_CONFIG_SMALL("3GPP AMR"),
--
2.40.1
More information about the ffmpeg-devel
mailing list