[FFmpeg-devel] [PATCH] libavcodec/mpeg12dec.c: append CC data to a53_buf_ref

Marth64 marth64 at proxyid.net
Sat Dec 14 07:39:56 EET 2024


This makes sense to me now.
I think it makes more sense to follow the A53
approach and be consistent.

May I suggest the following in the patch to also
improve readability in this crowded area of code:

- SCTE-20 section: as you are declaring `cap` to be
`s1->a53_buf_ref->data + old_size` now, the memset
immediately following the declaration can be shortened
to `memset(cap, 0, cc_count * 3);`

- DVB 0502 section: rename `uint8_t* data` to `uint8_t *cap`
when you are setting up the final payload.
This makes it more consistent with the other sections.

In the meantime I will test locally and await other feedback.

Thank you very much.


More information about the ffmpeg-devel mailing list