[FFmpeg-devel] [PATCH 05/10] avfilter/overlay_vulkan: use FF_ARRAY_ELEMS instead of magic number
Lynne
dev at lynne.ee
Thu Nov 18 07:48:26 EET 2021
Nov 18, 2021, 05:24 by jianhua.wu at intel.com:
> Signed-off-by: Wu Jianhua <jianhua.wu at intel.com>
> ---
> libavfilter/vf_overlay_vulkan.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/libavfilter/vf_overlay_vulkan.c b/libavfilter/vf_overlay_vulkan.c
> index b902ad83f5..29eb11c89d 100644
> --- a/libavfilter/vf_overlay_vulkan.c
> +++ b/libavfilter/vf_overlay_vulkan.c
> @@ -145,7 +145,7 @@ static av_cold int init_filter(AVFilterContext *ctx)
>
> ff_vk_set_compute_shader_sizes(ctx, shd, CGROUPS);
>
> - RET(ff_vk_add_descriptor_set(ctx, s->pl, shd, desc_i, 3, 0)); /* set 0 */
> + RET(ff_vk_add_descriptor_set(ctx, s->pl, shd, desc_i, FF_ARRAY_ELEMS(desc_i), 0)); /* set 0 */
> RET(ff_vk_add_descriptor_set(ctx, s->pl, shd, &desc_b, 1, 0)); /* set 1 */
>
> GLSLD( overlay_noalpha );
>
Thanks for all the patches, but it's getting difficult for me to maintain
my Vulkan hwaccel branch with all changes. Would you mind waiting
a bit for me to push the patch I just submitted and then rebasing all the
patches you submitted?
More information about the ffmpeg-devel
mailing list