[FFmpeg-devel] Rename RSHIFT macro to ROUNDED_RSHIFT

Uoti Urpala uoti.urpala at pp1.inet.fi
Tue Jan 22 21:31:12 EET 2019

On Tue, 2019-01-22 at 15:35 -0300, James Almer wrote:
> I'm not against renaming it to AV_ROUNDED_RSHIFT or similar, but other
> than an entry in APIChanges we have no way to let library users that
> RSHIFT will be removed two or so years from now.

How about:
static inline void  __attribute__ ((deprecated)) RSHIFT_is_deprecated(void) {}

#define RSHIFT(a, b) (RSHIFT_is_deprecated(), AV_ROUNDED_SHIFT(a, b))

More information about the ffmpeg-devel mailing list