[FFmpeg-devel] [PATCH 5/6] opus_celt: rename structures to better names and reorganize them
michaelni at gmx.at
Wed Feb 1 13:51:22 EET 2017
On Wed, Feb 01, 2017 at 03:13:08AM +0000, Rostislav Pehlivanov wrote:
> This is meant to be applied on top of my previous patch which
> split PVQ into celt_pvq.c and made opus_celt.h
> Essentially nothing has been changed other than renaming CeltFrame
> to CeltBlock (CeltFrame had absolutely nothing at all to do with
> a frame) and CeltContext to CeltFrame.
> 3 variables have been put in CeltFrame as they make more sense
> there rather than being passed around as arguments.
> The coefficients have been moved to the CeltBlock structure
> (why the hell were they in CeltContext and not in CeltFrame??).
> Now the encoder would be able to use the exact context the decoder
> uses (plus a couple of extra fields in there).
> FATE passes, no slowdowns, etc.
This doesnt build on arm-linux-gnueabi-gcc-4.5
(i think arm is unrelated here)
In file included from src/libavcodec/opus_celt.c:28:0:
src/libavcodec/opus_celt.h:134:3: error: redefinition of typedef ‘CeltFrame’
src/libavcodec/opus.h:82:26: note: previous declaration of ‘CeltFrame’ was here
make: *** [libavcodec/opus_celt.o] Error 1
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
No great genius has ever existed without some touch of madness. -- Aristotle
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 181 bytes
Desc: Digital signature
More information about the ffmpeg-devel