[FFmpeg-devel] [PATCH 3/3] vf_colorspace: Add support for smpte 431/432 (dci/display p3) primaries
vittorio.giovara at gmail.com
Mon Oct 31 21:31:23 EET 2016
On Mon, Oct 31, 2016 at 2:53 PM, Ronald S. Bultje <rsbultje at gmail.com> wrote:
> On Mon, Oct 31, 2016 at 11:13 AM, Vittorio Giovara
> <vittorio.giovara at gmail.com> wrote:
>> On Mon, Oct 31, 2016 at 7:43 AM, Ronald S. Bultje <rsbultje at gmail.com>
>> > Hi,
>> > On Mon, Oct 31, 2016 at 5:50 AM, Kevin Wheatley
>> > <kevin.j.wheatley at gmail.com>
>> > wrote:
>> >> On Sun, Oct 30, 2016 at 1:18 PM, Ronald S. Bultje <rsbultje at gmail.com>
>> >> wrote:
>> >> > Hmm... So, the wikipedia page https://en.wikipedia.org/wiki/DCI-P3
>> >> > refers
>> >> > to the two whitepoints here as DCI-P3 D65 and DCI-P3 Theater. Calling
>> >> > one
>> >> > D65 and the other DCI seems confusing in that light (assuming the
>> >> > wikipedia
>> >> > page is correct). I'd call it THEATER or DCI_P3_THEATER, to
>> >> > distinguish
>> >> > it
>> >> > from DCI-P3 D65. Is that OK?
>> >> In the industry people just call it the DCI P3 white point (or 'Urgh')
>> >> it is not limited to theater usage, you might consider it the
>> >> calibration white point for the reference projector, so
>> >> WP_DCI_P3_REFERENCE might be better, but that is a little long.
>> >> I'd go for something like WP_DCI_P3 it is not really ambiguous.
>> > Hm... OK with me (though not ideal, but what do I know). Vittorio, OK
>> > also?
>> > I can modify patch so you don't have to resend.
>> I find it a little long and not less confusing than my initial WP_DCI,
>> among all the alternatives I liked the THEATER one the most. If that's
>> a no-go, how about we could settle for WP_PROJ maybe?
> Wait, wait. Length is an issue? Really?
> The only reason the other names are short is because the names of the
> whitepoints are short. D65 is really just called that: D65. Likewise for
> D50. This name (whatever it is :D) is simply longer.
It's not a matter of length but a matter of descriptiveness: right now
there is only one single different whitepoint defined by DCI, so IMO
it makes sense to call it simply WP_DCI. In case DCI adds new values,
naming can be modified later. The other whitepoints could also have
longer, more descriptive names too, like WP_ILLUMINANT_C, but at the
same time the WP_C shorthand is convenient and immediate (and IMO
better suited as variable name).
At any rate, pick the one you prefer ;)
More information about the ffmpeg-devel