[FFmpeg-devel] [PATCH] avformat: Add Pro-MPEG CoP #3-R2 FEC protocol

Vlad Tarca vtarca at mobibase.com
Thu Jun 2 14:36:59 CEST 2016


> also why are some called _size and some _len ?

I will use length_recovery as it's named exactly like that in the code of
practice and use better names for the rest.
The size check will also take into account UINT16_MAX and not INT_MAX since
the recovery field is only 16-bit.

> -    ret = ffurl_write(hd, buf, size);
> +    if ((ret = ffurl_write(hd, buf, size)) < 0) {
> +        goto end;
> +    }
> +
> +    if (s->fec_hd && !RTP_PT_IS_RTCP(buf[1])) {
> +        if ((ret_fec = ffurl_write(s->fec_hd, buf, size)) < 0) {
> +            av_log(h, AV_LOG_ERROR, "Failed to send FEC\n");
> +            ret = ret_fec;
> +        }
> +    }
> +
> +end:
>      return ret;

> the goto isnt needed, a direct return can be used
> also is ret_fec needed and cant ret be used directly ?

The reasoning here was that rtp_write() should return the result of the RTP
write operation on success, and not that of the FEC write.
If there's a better way let me know and I will implement it.

Thanks.


More information about the ffmpeg-devel mailing list