[FFmpeg-devel] [PATCH] diracdec: add support for field coding
Carl Eugen Hoyos
cehoyos at ag.or.at
Tue Jan 26 15:45:18 CET 2016
Rostislav Pehlivanov <atomnuker <at> gmail.com> writes:
> - for (y = 0; y < p->height; y += 16) {
> - ff_spatial_idwt_slice2(&d, y+16); /* decode */
> + for (y = 0; y < p->height; y += 16)
> + ff_spatial_idwt_slice2(&d, y+16);
Sorry if it's just me but don't you agree that this is
much more readable without the unneeded changes?
(Apart from git blame.)
> + if (s->field_coding && s->cur_field) { /* Copy the top field */
> + int x, y;
> + uint8_t *src = s->prev_field->data[comp];
> + for (y = 0; y < p->height; y++) {
> + for (x = 0; x < p->width*2; x++)
> + frame[p->stride*y*2 + x] = src[p->stride*y*2 + x];
Can't you avoid this?
Carl Eugen
More information about the ffmpeg-devel
mailing list