[FFmpeg-devel] [PATCH v2] libi264: Add Hardware Accelerated H.264 Encoder based on libVA
wkelleher at gogoair.com
Tue Jan 12 20:28:36 CET 2016
On 01/12, Hamza Shahid wrote:
> Hi Will,
> I think we addressed all the review comments in this patch. Which are as
> 1. Remove inline asm for color conversion and replace with swscale, which I
> 2. Replace static variables with #defines, which I did.
> 3. Remove unnecessary stuff from configure script, which I did.
> 4. Use named constants instead string to constant conversion function,
> which I did.
> 5. configure script was broke, which I fixed.
> Can you please be a bit more specific about which comments did we not
> address. I will be more than glad to fix everything and get this patch
There were comments on the "libi264" naming (Carl Eugen and Hendrik Leppkes, at
least), and I agree with them. This would make more sense if it used the
"libva" or "vaapi" naming conventions and existing config flags. Ideally there
is nothing Intel-speciic about the implementation itself, even if you are using
it with the Intel driver.
It would be nice if the naming also left open the possibility of adding support
for other codecs using this same interface in the future. The QSV codec, for
example, uses a naming scheme where the API comes first, followed by the
specific codec (h264 or hevc). So something like "vaapi_h264" would work well
More information about the ffmpeg-devel