[FFmpeg-devel] [PATCH] AAC: [PATCH] AAC: Add support for 7350Hz sampling rates

Michael Niedermayer michaelni at gmx.at
Fri Mar 13 12:30:30 CET 2015

On Fri, Mar 13, 2015 at 04:42:36AM -0300, Claudio Freire wrote:
> On Tue, Mar 10, 2015 at 10:08 AM, Claudio Freire <klaussfreire at gmail.com> wrote:
> > On Tue, Mar 10, 2015 at 8:05 AM, Michael Niedermayer <michaelni at gmx.at> wrote:
> >>> I cannot test myself yet (cannot build against mips, it will
> >>> probably take me a long while before I can set up qemu for that), but
> >>> the patch should bring both implementations in sync, at least enough
> >>> for the test to pass without the -b:a 88k
> >>
> >> if you use a debian based distro then the packages from
> >> http://www.emdebian.org/
> >> can probably be used to cross compile to mips
> >> (you might need to force some versions manually during install, at
> >>  least in the past the binary packages referred to many non existing
> >>  package versions so only some versions of the packages had all
> >>  dependancies available)
> >
> > I don't have any debian or its derivatives at hand sadly. I may
> > unearth an old laptop that had some form of ubuntu at some point, it's
> > old and slow but that shouldn't be a problem for this sort of thing,
> > but that will have to wait until next week.
> >
> > In the meantime I'm trying to make cross-mips-linux-gcc work on
> > openSuse without much luck yet.
> I got lucky and was able to cross-build in openSUSE.
> Just in case others also use openSUSE, I put the instructions on the
> wiki (I hadn't found any, if there are, I'll welcome pointers and I'll
> merge them): http://trac.ffmpeg.org/wiki/CompilationGuide/MIPS

> I confirmed that the previous patch does fix the test on mips.

i tried again:

43a1cc5 Add AAC tests for 7350hz sampling rates and M/S
 tests/fate/aac.mak |   29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
c5e02b1 AAC: [PATCH] AAC: Add support for 7350Hz sampling rates
 libavcodec/mips/aaccoder_mips.c |   26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

i tried 2 qemu versions, i tried with and without
--disable-mipsdspr1 --disable-mipsdspr2 --disable-mipsfpu

but i still get this

stddev:  443.22 PSNR: 43.40 MAXDIFF: 5038 bytes:   176400/   180224
stddev: |443.22 - 414| >= 5
Test aac-s7350-encode failed. Look at tests/data/fate/aac-s7350-encode.err for details.

mips-linux-gnu-gcc-4.4 (Debian 4.4.5-8) 4.4.5

btw, i use the qemu from https://github.com/ssvb/QEMU.git
for mips as it at least years ago supported more extensions, i
would have guessed these where merged into main qemu but as you list
all the disables in the wiki, maybe i was guessing wrong

can you repost the patchset that works for you ?
so to make double sure we use the same code

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

I have never wished to cater to the crowd; for what I know they do not
approve, and what they approve I do not know. -- Epicurus
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: Digital signature
URL: <https://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20150313/63fe9478/attachment.asc>

More information about the ffmpeg-devel mailing list