[FFmpeg-devel] [PATCH] lavfi: add erosion & dilation filter

Paul B Mahol onemda at gmail.com
Fri Feb 27 09:19:08 CET 2015


On 2/26/15, James Almer <jamrial at gmail.com> wrote:
> On 25/02/15 11:55 AM, Paul B Mahol wrote:
>> +static inline void line_copy8(uint8_t *line, const uint8_t *srcp, int
>> width, int mergin)
>
> Unless I'm missing something, "mergin" seems to always be 1.
> The code below could be simplified.

The function could be used with other arguments for mergin in later patch(es).
>
>> +{
>> +    memcpy(line, srcp, width);
>> +
>> +    for (int i = mergin; i > 0; i--) {
>> +        line[-i] = line[i];
>> +        line[width - 1 + i] = line[width - 1 - i];
>> +    }
>> +}
>
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>


More information about the ffmpeg-devel mailing list